0 votes
by (120 points)

Hello. I’m developing a VR app using OpenXR. It works perfectly on Oculus Quest 1 and 2, but if I try to run it on Pico Neo 3, everything goes fine (Loader Init, Instance Init, System Init, Session Creations, Visualized Spaces and Swapchains creation) until I start polling events with XrPollEvent in order to get session state changed and then start it. The session state changes ones - from UNKNOWN to IDLE, and then always stays in IDLE. From this point XrPollEvent always results in EVENT UNAVAILABLE. For the loader I use .so library that I got from Pico OpenXR sample from your official site, the Android Manifest is also from sample. Version of OpenXR header files is 1.0.14 (it is used in Pico sample. I also tried 1.0.24 headers with same result). Worth to mention that Pico sample is running perfectly on Pico Neo 3. So I’m trying to understand what can be the problem. Thanks.

1 Answer

0 votes
ago by (37.0k points)

Dear Developer,
Would you please send us your test project? It is convenient for us to test and find the problem.

...