0 votes
by (150 points)

Hello, I'm trying to test a new created project and it shows "Loading..." and then crashes. I tried everything I could think of, but no luck.. so I decided to reach out for help and support, I'm really stuck.

Here is info about the setup that I have here:

Pico Neo 3 Pro (enterprise)
Unreal Engine 4 (4.27 and 4.26 are installed, same problem on both)
Android Studio SDK 8.0 - 10.0
Visual Studio 2019

In unreal they are set as:
ndk: android-29
sdk: matchndk

package all in apk, mobile hdr disabled, all other VR plugins and input devices disabled like the documentation says, all done.
Inside the editor I can see pico in input and I can see the blueprint functions (pico sdk is in the correct folder)

but the problem is this:
if I set the pico sdk to false, project compiles as apk shipping build, pico VR opens it in a 2D window like any other app
if I set the pico sdk to true, project compiles as apk shipping build, pico VR starts to load it, then crashes and closes it automatically..

I looked into android keystroke, double checked java and android studio (same app works on both pico vr and my mobile phone, if the pico sdk is disabled)
Also tried to add a c++ class and make sure dependencies for pico online plugin are added.

have I missed a step somewhere? what else do I need to do to create a working development app?

1 Answer

0 votes
by (39.1k points)
selected by
 
Best answer

Dear developer,
Could you please tell us what is the PUI version of your device and the SDK version you use?

by (150 points)

PUI: 4.2.78
SDK: 2.0.5

Other
Unreal Engine: 4.27.2 and 4.26.2 (both from launcher installed, not custom engine)
Android SDK Platforms: 21-32
Android NDK: 21.4.7075529
Android CMake: 3.10.2.4988404
Visual Studio 2019 Community Edition

by (39.1k points)

Dear developer,
The version requirementsof Rom for this SDK are C000RF01bv1.0.1sv1.18120211022_b335 or later. And you can put on your Pico VR Headset, and go to Settings->General to check the software Rom version.
The device needs to upgrade PUI to the latest system to run applications integrating the latest SDK.
You can refer to the following documentation for more information about the SDK version requirements:
https://developer.pico-interactive.com/docs/en/12058/unreal-xr-sdk-quickstart/#version-requirements

by (150 points)

Thanks, yep can confirm that it all works as expected now. It was indeed a firmware issue, after the update it all works fine. Thank you for your help, cheers.

...