0 votes
by (320 points)
edited by

I can't figure out how to get it to work. I install the app from the website and launch it in the neo 3 and it says I need to update the firmware because they don't match. I really would like to be able to use this. I just got it today and I'm pretty frustrated since the streaming doesn't connect or work.

Updated from unknown version to 4.6.3 when I setup originally.

I tried windows 11 and windows10 both have the same error within the neo 3.

Please help me with either downgrading or upgrading firmware on the Pico neo 3 or finding the correct streaming assistant.

Factory reset the Pico neo 3. Still not working with my computer.
I really need this working if not this headset will go in a box and will not consider this Brand in the future

Next I Pushed the 4.6.3 update using "dload" thinking the streaming assistant app would change. Still not working. This headset is as good as a paper weight

Both of the useless pc versions I tried:
Pico link version 1.05
Streaming assistant version 7.2.2

1 Answer

0 votes
by (320 points)

the fix was to find the old version 8.0.6 of the streaming software. i was able to find it using a way back machine to get the link to download it. i couldn't find anyone to help me so i had to figure it all out myself. i don't understand why they release the new app if they have the old firmware still on the neo 3 which causes this issue. they should keep both versions available incase of this. it also brings the other app for the other headsets to its knees since they also will be relaying on the new app but the new app doesn't work with anything

https://source.picovr.com/website/cn/vsa/PicoVRStreamingAssistantInstall-8.0.6_B118-20220129.exe

by (120 points)

Got the same issue as you, downloaded the old version and it work now. Pico really need to update their software because nobody is going to figure this out

...