0 votes
by (210 points)
edited by

Just to be clear and precise:

When i download the zip called: PicoPreviewTool V1.0-0402.zip
Within i only find a new folder: PicoPreviewTool V1.0-0402
within that i find a new 7z: PreviewTool0402Release.7z
within this there is a folder called Release.

In Release folder there is the excecuteable file called "PreviewTool.exe"
and this is what i run.

have i missed some installation step here, or is this the intented "installation" we are talking about?

When running the application, there is no new adaptor added for my network, there is no error or other reason stated that the adaptor was not added.

Windows 10.
Windows Firewall completely disabled.
Windows Defender completely disabled.
Tried USB 1-2-3 and using the original cable from the pico charger.

I hope you can direct me as to why this adaptor might not be added?

Kind Regard

1 Answer

0 votes
by (24.7k points)
selected by
Best answer

Dear developer,
You have not missed the installation steps on the PC, you can directly run PreviewTool.exe on the PC side.
For wired connection, are you using Pico Neo 3 or Pico Neo 3 Pro?
For Pro devices, you can try using the DP port for wired connections.
In addition, if have any anti-virus software, try turning it off and see if it works.
Hope this information can help.

by (210 points)

We are using PicoNeo 3 Pro
I tried using both USB-C ports on the headset, and using the DP (right USB-C port on headset) gave a much better response, now the software detects that USB was connected, however point 1. was still unsuccesfull, so I have ordered a display port to USB-C cable so i can direct connect between the graphics card and the pico.

(I assume this is what is needed or should it be enough with USB to USB-C DP?)

Best Regards

by (210 points)

After tinkering with the headset and windows firewall + windows Anti-virus, I have managed to get through to the headset using the USB to USB-C.

The PC software would not reconize the connection in the beginning, but after quitting the software on the headset, and manually starting it, and doing a direct connect, the headset finaly connected to the PC.

After that the headset was simply blank, which felt odd, but eventually when running Unity in playmode, the headset came to life but oddly displayed a static grey view in both headset camera and in unity gameview.

It is accompanied with the following error:

IndexOutOfRangeException: renderPassIndex
UnityEngine.XR.XRDisplaySubsystem.GetRenderPass (System.Int32 renderPassIndex, UnityEngine.XR.XRDisplaySubsystem+XRRenderPass& renderPass) (at <86879d5915394890a62dd42337ed228f>:0)
UnityEngine.Rendering.Universal.XRSystem.CreateLayoutFromXrSdk (UnityEngine.Camera camera, System.Boolean singlePassAllowed) (at Library/PackageCache/com.unity.render-pipelines.universal@10.5.1/Runtime/XR/XRSystem.cs:332)
UnityEngine.Rendering.Universal.XRSystem.SetupFrame (UnityEngine.Rendering.Universal.CameraData cameraData) (at Library/PackageCache/com.unity.render-pipelines.universal@10.5.1/Runtime/XR/XRSystem.cs:180)
UnityEngine.Rendering.Universal.UniversalRenderPipeline.RenderCameraStack (UnityEngine.Rendering.ScriptableRenderContext context, UnityEngine.Camera baseCamera) (at Library/PackageCache/com.unity.render-pipelines.universal@10.5.1/Runtime/UniversalRenderPipeline.cs:490)
UnityEngine.Rendering.Universal.UniversalRenderPipeline.Render (UnityEngine.Rendering.ScriptableRenderContext renderContext, UnityEngine.Camera[] cameras) (at Library/PackageCache/com.unity.render-pipelines.universal@10.5.1/Runtime/UniversalRenderPipeline.cs:241)
UnityEngine.Rendering.RenderPipeline.InternalRender (UnityEngine.Rendering.ScriptableRenderContext context, UnityEngine.Camera[] cameras) (at :0)
UnityEngine.Rendering.RenderPipelineManager.DoRenderLoop_Internal (UnityEngine.Rendering.RenderPipelineAsset pipe, System.IntPtr loopPtr, System.Collections.Generic.List`1[T] renderRequests, Unity.Collections.LowLevel.Unsafe.AtomicSafetyHandle safety) (at :0)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr, Boolean&)

by (24.7k points)

Dear developer,
For error IndexOutOfRangeException: renderPassIndex problem, it is expected to be fixed in the next version of the SDK.