0 votes
by (230 points)

As you can see in the image below, there's quite a few bindings I've set for the TalkButton. However even though these work fine on the Pico Neo 3 and the Oculus Quest 2, the G2 doesn't seem to trigger any of these inputs.

I have tried this with "Both" and "Input System Package (New)" selected for Active Input Handling but no luck with either of them.

Does anyone know what bindings work on the G2 so I can activate the speech module in my game?

Thank you in advance for any answers :)


1 Answer

+1 vote
by (35.2k points)
selected by
Best answer

Dear developer,
Could you please tell us the device model? And your PUI version and SDK version?
And could you please provide a Demo project that can reproduce your problem?
Please send it to our email: pico_devanswers@bytedance.com.
We'll test it.
And please use the title of your question as the subject of your email.

Note: If the attachment size exceeds the upper limit and the email is returned, plesae send it as a download link.

by (230 points)

After trying to reproduce this in a demo project and doing some further research I think this was an issue on my side as I was unable to reproduce this outside my project.

Still not sure why it happens but I have managed to fix it, thanks for the help anyways!