0 votes
by (920 points)

Hi there,

As said, the SystemKeyConfig.prop cannot be applied/ even though it is pushed to device.

I had the same problems in past (2021) but then you had sent me an apk fixing the problem.
Some days after the PUI 4.0.7 came and somehow fixed the problem (to our other devices).

Now, we have the same problem with a device that has recently factory reset and upgraded to PUI 4.0.7

PS: Is there any developer settings that may affect it, although I had it running correctly in the past with the same settings..

ThanX

1 Answer

0 votes
by (39.1k points)

Dear developer,

Could you check whether the SystemKeyConfig.prop file is in /data/local/tmp?
enter image description here
And whether the SystemKeyConfig.prop file is correct?
The following is the official systemKeyConfig.prop file
https://github.com/picoxr/system-key-config-runtime/blob/master/resource/SystemKeyConfig.prop

by (920 points)

Hello,

Tried the tmp folder had these things:

  1. PxrSystemKeyConfig.prop
  2. SystemKeyConfig.prop
  3. launcher-debug.apk

I pushed a, downloaded from your given source, SystemKeyConfig.prop with a slight differential (uncomment the tap on power) but nothing changed.

I proceed to a factory to reset the mask and did the bug-fixing upgrade (PUI 4.0.7).

Tried again and worked fine!

So, I assume that it would be a reason for blocking it to work.
(a) I had several Developer settings modifications, so I assume it is something somewhere there, or maybe (b) a bug on the order of doing things, since this device had Enterprise interface, Settings modifications, video kiosk mode, etc. in a succession, so a file was created in the past might block the Key - configuration file.

Do you have any idea, what settings in assumption (a) might block the SystemKeyConfig.prop?
or what might happen in assumption (b)?

Thank you.

by (39.1k points)

Dear developer,
Please try deleting the PxrSystemKeyConfig.prop file,
The file has a higher priority than SystemKeyconfig.prop. As a result, SystemKeyConfig.prop does not work.

...