0 votes
by (27.7k points)

Preview Tool v1.0 is released:

v1.0 Updated Content:

Released the Preview Tool. The detailed introduction is as follows:
When developing applications through Pico Unity/Unreal XR Plugin, the Preview Tool allows developers to preview their applications in real time using the Unity/Unreal Editor. Based on the preview, developers can debug applications in real time according to actual needs. In addition, with the Preview Tool, developers can test game levels using Unity/Unreal Editor without having to package and install APK files.

5 Answers

0 votes
by (1.1k points)


0 votes
by (5.3k points)


0 votes
by (520 points)

什么时候PC端可以支持Mac OS呢

by (27.7k points)

抱歉给您带来不便,目前没有支持Mac OS的计划。

0 votes
by (830 points)


by (27.7k points)


0 votes
by (160 points)

Hi, i'm trying to use this tool on a Pico neo 3 Link with a WiFi connection.

I have followed the documentation, and both the PC and the VR are connected to the same WiFi connettion (is a 5Ghz connection)

When i link both the tool on pc and vr, on the PC show the message that i'm connected
instead in the headset appear a loading screen that loop infinitely without having possibility to do anything else, and i'm forced to turn off the headset.

Am i doing something wrong?

by (27.7k points)

Dear developer,
Could you please tell us what engine and SDK version you use and what PUI version you use?
Whether the tool works properly the first time, the device cannot display the content the second time.
In addition, have you tried the wired connection?

ago by (160 points)

Hi, i'm currently using Windows 10 as OS and a Pico Neo 3 Link to test this tool
The SDk of the preview version is the 1.0 and the PUI of the pico is

I've tried both wifi and wired connection with a 3.0 usb port. in both the cases when i start the preview tool from PC and then the tool from the Pico, the Pico screen show a loading infintie loop and if I take of the connection between the pico and the PC, in the Pico still show the Loading screen.

I tried to se in the adb what message it show and i found this:

ContextImpl: Calling a method in the system process without a qualified user: android.app.ContextImpl.sendBroadcast:1045 android.content.ContextWrapper.sendBroadcast:448 com.picovr.streamingapplication.executor.USBTetheringExecutor.lambda$enableUsbTethering$1$USBTetheringExecutor:223 com.picovr.streamingapplication.executor.-$$Lambda$USBTetheringExecutor$2VL21K_4izhIj6m9MwE-TH7IgoA.accept:4 io.reactivex.rxjava3.internal.observers.LambdaObserver.onNext:63