0 votes
in English by (570 points)

Hi,

I am trying to use the PreviewTool to directly debug my applications from the Unity Editor.
Thereby I encountered two errors:

1) I can only connect via WiFi - when connecting via USB, after clicking the blue highlighted "Wired Connection" Button, no connection is built (only loading visualization pops up and disappears again). The headset is detected by the computer as an external storage device. Are there any suggestions on how to solve this (e.g. special USB cable to use)?

2) When connected and pressing the play button in the Unity Editor, the Editor throws an "IndexOutOfRange:renderPassIndex"-Exception. The image is displayed somewhat distorted (like it is extremely zoomed in) and the XRRig changes its position in the scene.

I am using Unity 2020.3.25, SDK v2.0.4, and URP. Headset PUI Version is 4.5.30.
Thanks for your help!

2 Answers

0 votes
by (1.3k points)

I also have this problem when using the unreal engine. Have you solved it now?(only loading visualization pops up and disappears again)

0 votes
by (36.6k points)

Dear developer,
Sorry for the inconvenience,

For question one:
A wired connection will generate a virtual network on the PC. Generally, a connection failure may be caused by firewall interception or virtual network generation failure.
Try turning off the firewall or adding previewTool to the whitelist, or restart your computer and try again to see if the virtual network is properly generated.

For question two:
The problem of screen content showing too large(like it is extremely zoomed in), it will be optimized in the next version.

For the use of URP will be in the editor to IndexOutOfRangeException: renderPassIndex wrong question,
We replicated the problem and fed it back to r&d.

by (570 points)

Thank you for your answer.

Unfortunately, neither whitelisting the app nor turning off the firewall entirely solved the problem.
Are there any requirements for the USB Cable, that need to be fulfilled for it to work? Any other ideas to solve the problem?

by (36.6k points)

Dear developer,

Sorry, the problems may be different due to different PC hardware and software environments.
Advised to try the following:
1. Try to change other usb data cable;
2. Try other USB 3.0 port.
3. If you can, switch to another computer and see if the connection is successful.
4. If you have anti-virus software or other software that may be blocking the connection request, try turning off the anti-virus software.

...