+1 vote
by (130 points)

Unity 2019.4.0f1
PicoVR UnitySDK 版本: 2.8.12B583
Pico 设备:Neo 3
PUI 版本:4.4.7

测试打包Demo:打包场景为 官方SDK中Scene: PvrControllerUI.scene
enter image description here
现象:打开该未知包运行。可以正常运行Demo,但是不久会疯狂报错
OPENGL NATIVE PLUG-IN ERROR: GLINVALIDOPERATION: Operation illegal in current state
(Filename: ./Runtime/GfxDevice/opengles/GfxDeviceGLES.cpp Line: 353)
测试过打开项目,不进行任何操作,过一分钟左右,也自动报错。
enter image description here
AndroidManifest.xml
enter image description here
enter image description here
打包设置:
enter image description here
enter image description here
enter image description here
enter image description here
enter image description here

1 Answer

0 votes
by (55.5k points)

开发者您好,

请问您是否同时还有OPENGL NATIVE PLUG-IN ERROR: GLOUTOF_MEMORY或者其他相关Log?

您可以尝试一下使用2019.4.31f1c1的Unity版本是否还会出现这一问题。

by (130 points)

首先 Log 只有 OPENGL NATIVE PLUG-IN ERROR: GLINVALIDOPERATION: Operation illegal in current state
无其他 OpenGL的报错。
第二,使用 2019.4.31f1c1 Unity 确实解决了问题。

...