+3 votes
by (300 points)

This issue has suddenly appeared on 3 separate headsets in the last 24 hours. Prior to this, we were able to turn on passthrough mode so the user can see the room by simply doing this:

PXR_Boundary.EnableSeeThroughManual(true);

Since January 26th 2022 this no longer works with existing builds and installs (some several weeks old); the functionality is ignored. Prior to this, the skybox would be replaced with the headset camera view.

We tried resetting the devices, updating the sdk to 2.03, and building a test scene. One of our developers indicated the original C# code for this came from the pico github repository, but we can no longer find it.
Was there some sort of over the air automatic update that changed things, or is there some other method we should be doing to enable a see through/pass through mode, or is there is standalone github repository that demos this functionality?

1 Answer

0 votes
by (55.5k points)

Hello, please check whether the Settings of the camera have been modified.

enter image description here

by (300 points)

Yes, that is (and has always been) the settings for the camera.

I will point out that the cameras do work in the system's boundary setup part, so they are not broken in that regards. It is just this method call now does nothing when it used to work fine with deployed builds several weeks old.

by (300 points)

Also, this is not an answer and does not resolve the issue, so I cannot mark this question as answered.

by (55.5k points)

Dear developer,
This is our test APK to see if it works on your devices.
https://drive.google.com/file/d/1QIbfARGgBsEAiy3oxB2ccSrsoNbenvzm/view?usp=sharing

Press Confirm Button to enable SeeThrough.
Press Return Button to disable seeThrough.

Our test environment is as follows:

PUI version: 4.4.7 (C000RF1BV1.0.1SV1.19320211119_B348)
Unity version: 2020.3.26 f1
SDK version: Unity XR SDK v2.0.3

Could you please provide your test APK or project and send it to our email? pico_devanswers@bytedance.com
Please also write down your PUI version and use the subject of your question as the subject of your message.

by (300 points)

This test APK works on the headset - I press the headset button and the camera passthrough enables.

Would it be possible to get a copy of the Unity project that created this APK so that we can see what we are doing wrong (and maybe figure out how it was working for such a long time if we were)?

by (55.5k points)

Dear developer,
The download link for the project files is as follow:
https://drive.google.com/file/d/1IJxR4HuZdAH_Q_EEl50TW5dl_yvpfpJl/view?usp=sharing

by (300 points)

Thank you; we have downloaded this and built it using both unity 2020 and 2021.2.9 and the sample projects do work on the headset so that is a good starting point.

We exported the scene and it's dependencies (there are almost none) and imported those into our existing project, setting the Build options to build ONLY that new Sample scene.

Surprise! The Sample scene from your Working sample does not enable passthrough in our proect, just like our own code! So there must be some project setting somewhere that is causing this to block now. We have tried copying the project settings from BrokenProject to your Working Sample and your Working Sample continues to work.

Do you have any insight into what Unity setting might be responsible for this odd behavour?

by (55.5k points)

Dear developers,
Maybe there is a conflict in some Settings. We followed the instructions and did not change the other Settings.
http://developer.pico-interactive.com/document/doc

You can check to see if the settings are different.

by (300 points)

We have isolated the problem is to the PicoXR setting "Stereo Rendering Mode" being set to Multiview. With this mode set to Multiview, the passthrough setting no longer works. You can duplicate this in the sample project that was posted by going into Project Settings, Xr Plugin Management, PicroXR and change the Stereo Rending mode from Multi Pass to Multiview and running the built apk. Passthrough will no longer work until you switch back to Multi Pass.

What is the official way to file a bug report for the incompatibility of Multiview with Passthrough?

Also, again, our project had been using the Multiview setting from day one and again, older binaries that were deployed and working no longer do (so this is not an SDK, local setting, or recent Unity version change on our side). We still feel that something has changed in the headset firmware when an over-the-air update was delivered but do not have access to older firmware versions to confirm this as of yet.

by (55.5k points)

Dear developers,

We'll try to reproduce this issue

by (160 points)

Any news on that topic ? Seems we still can't use Pass/Seethrough when Multiview is on...

...