+1 vote
by (160 points)
edited by

Is there any way to enable boundary for applications (games) on Pico Neo 3? I am working with project developed on Pico Neo 2. And boundary system worked there fine. But now I decided to use Pico Neo 3. And on this new device boundary works only in Pico main menu.

P.S. I've also checked boundary in Pico demo apps (Tobii demo app and EyeTracking demo apps) and boundary in these apps did not work as well.

1 Answer

0 votes
by (55.5k points)
selected by
 
Best answer

Dear developer,

Could you please consider telling us what the specific symptom of "did not work" is? Is it you can move freely around the scene without any indication of safety boundary even when you are far away from the UI?

Please provide your PUI version as well. We suggest you do "Online Update" if your PUI version is not the latest.

by (160 points)

"Is it you can move freely around the scene without any indication of safety boundary even when you are far away from the UI?" -- yes, exactly. So, firstly I setup safety boundary and tested it in Pico menu. Everething works fine. If I cross created safety circle, I see warning wall and than after moving outside "See-Through" mode activating. On Pico Neo 2 all of this works good in Pico menu and in all applications as well. But on Pico Neo 3, when I start some app (my app made with Unity or Pico demo apps) safety boundary does not appear when user approaches it. So, using some app on Pico Neo 3 you can go as far as you want, even if your safety boundary activated. Maybe I should acivate it for applications somewhere in developer options or something like that?
My current version of PUI: 4.4.7

by (160 points)

I also downloaded several free games from Pico App Store. Safety boundary does not appear in these games and I can move freely as well.
Games I've tested: Golf Pool VR, Legendary Hunter VR

by (55.5k points)

Hi,

We tested those applications and games on our devices(Neo 3 Pro Eye, PUI v4.4.7) but could not reproduce the problem. Here is the screen recording of our test:

https://drive.google.com/file/d/1yFfWHbxB_ZhI5C_F9FYj5kc16ptd80La/view?usp=sharing

Sorry for the inconvenience but we suggest that you reset your device. You can find “Factory Reset” in “Settings” - “General” - “Reset”.

by (160 points)

Reset really helped me. Thanks for advice!)
But it's strange that me and client, I am working with, have the same problem.

...