0 votes
by (240 points)
edited by

This page: https://sdk.picovr.com/docs/UnrealXRSDK/en/chapter_two.html?highlight=vulkan#vulkan-rendering-development-configurations
describes how to enable Vulkan for UE 4.24 to UE 4.26
Where can I find instructions how to enable Vulkan support on UE 4.27?

Background
If I just enable Vulkan under project settings/android the app needs longer to load than normal an then I just have a black screen.
Can't nothing found out through the app log file.

1 Answer

0 votes
by (55.5k points)

Dear developer,

The fifth and sixth sections of that page( https://sdk.picovr.com/docs/UnrealXRSDK/en/chapter_two.html?highlight=vulkan#vulkan-rendering-development-configurations) are tutorials about enabling Vulkan on UE 4.27, you can follow the instructions there.

enter image description here

by (240 points)

Oh, my fault, I did not scroll down.
The problem is I need the source version of the editor since I want to build a dedicated server.
The other problem is I can not disable the openXR plugin since I use the VR Expansion Plugin which needs the openXR Plugin to be enabled
https://vreue4.com/

So for me it is not a satisfaction to use the non source version of the editor and disable openXR plugin.
So isn't there another way to enable vulkan?

by (55.5k points)

Hi,

As far as we know, you can use the source version of the editor. This will not affect Vulkan.

Based on the feedback we've received from other developers, they have tried enabling VR Expansion Plugin with OpenXR Plugin disabled, and VR Expansion Plugin works properly. You may also disable OpenXR Plugin and see if VR Expansion Plugin still works.

If you have further questions, please feel free to add comments.

by (240 points)
edited by

Based on the feedback we've received from other developers, they have
tried enabling VR Expansion Plugin with OpenXR Plugin disabled, and VR
Expansion Plugin works properly.

Which Version do they use? I assume also 4.27, since that's what we talking about.
VR Expansion Plugin comes with various extensions, also with "OpenXRExpansionPlugin"
So if I disable the OpenXR Plugin I get the message "This plugin is required by OpenXRExpansionPlugin. Would you like to disable it as well?"
If I do so and restart the editor I no longer can open the project and get the following message:

Assertion failed: false
[File:D:/UE4_SourceBuilds/UnrealEngine-4.27.2/Engine/Source/Runtime/Engine/Private/EdGraph/EdGraphPin.cpp] [Line: 1906]
Pin named StructOut was serialized while trashed - requesting pin named StructRef owned by node K2Node_SetFieldsInStruct_0

So the error must come from disableling OpenXRExpansionPlugin. If I just disable OpenXRExpansionPlugin and let OpenXRPlugin enabled I also get the message. But like I said, I have to disable OpenXRExpansionPlugin since it requires OpenXRPlugin.

I am using the following versions:

  • Unreal Engine 4.27.2 Source
  • VRExpansionPlugin, master from github
  • Pico Unreal XR SDK Version 2.0.2

Update
I managed to get the project work again without OpenXRPlugin. But if I build with vulkan enabled I get the same result as on the beginning.
App loads longer than normal and in the end I just have a black screen.

by (55.5k points)

Hi,

  1. Sorry for the inconvenience. At first you said VR Expansion Plugin, VR Expansion Plugin doesn't require OpenXR Plugin. But OpenXR Expansion Plugin does require OpenXR Plugin.

  2. For the black screen issue after disabling OpenXR Plugin, perhaps your runtime is not the latest version. You can download the latest version of runtime here. Please install it and then try building with Vulkan again.
    https://drive.google.com/file/d/1i8n7YnyilYT6FSnoRHdyzBcxxnw4Mo04/view?usp=sharing

by (240 points)

I installed the latest runtime but it changed nothing.
If I build with OpenGL ES3.1 everything works.
But if I untick OpenGL ES3.1 and tick Support Vulkan the app loads longer than normal and then gets closed.
In Logcat I have this error:

A/libc: Fatal signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0x10 in tid 22218 (RHIThread), pid 21982 (main)
by (55.5k points)

Could you please send the complete log file or your APK to our email address? We will check it out.
pico_devanswers@bytedance.com

by (240 points)

since i have to build it again I need some more time. the last days and a few days in future I have to do other stuff, but i will send you the apk as soon as I get to it.

...