0 votes
by (120 points)
recategorized by

设备信息(Equipment information)

  1. Pico VR 2
  2. U3D 版本(version):2018.1.0f2
  3. SDK版本(version): 最新 latest
  4. Android SDK: Platform-tools 29.0.6、29API,27API
    enter image description here

问题(Problem)
新建项目可以打包,但是当我导入SDK后不进行任何操作打包就会出现错误

The new project is packed error-free,but the package error is reported after the SDK is imported

Execution failed for task ':processReleaseResources'.
com.android.ide.common.process.ProcessException: Failed to execute aapt

但是我却安装了API29环境!尝试删除android:requestLegacyExternalStorage=”true”,但是会出现com.android.build.apitransform.TransformException

But I installed the API29 environment instead! Try to delete android: requestLegacyExternalStorage = "true", but there will be a com. Android. Build. Apitransform. TransformException

尝试很多网上的方法未果,希望能够得到解答

Try a lot of online methods failed, hope to get the answer

1 Answer

0 votes
by (55.5k points)

开发者您好,我们线上的SDK已经不支持2018.1.0f2版本的Unity了,我们建议您使用2019.4及以上的LTS版本的Unity进行开发。

您的设备可以使用Unity XR Platform SDK或者PicoVR Unity SDK进行开发,开发环境要求分别如下所示。我们建议您选择Unity XR Platform SDK,其对Unity的要求为2019.4.0及以上版本。

enter image description here

enter image description here

...