0 votes
by (120 points)
recategorized by

Unity 版本:2020.1.f1
Jdk:1.8
PicoVRUnitySDK:2.8.11
都是跟着文档说明一步步执行的,但是就是到打包这一步,一直报错,还请社区的大佬能解答一下
enter image description here
enter image description here
enter image description here
enter image description here
enter image description here

1 Answer

0 votes
by (30.5k points)

您好,您Android API 是否安装29及以上?Minimum API Level建议您选择26。

by (120 points)

有的,Android API是31的,Minimum API Level也按照您的指导选成了26,但是依旧报错Value cannot be nul的错误,在同样的位置

by (30.5k points)

您好,请问您方便将您的工程发到我们的邮箱吗?邮件标题为帖子的题目。
picodevsupport@bytedance.com

by (120 points)

邮件发出之后被退回了,是地址错误了吗?

by (30.5k points)

抱歉,邮箱地址为pico_devsupport@bytedance.com。

by (120 points)

好的,收到

by (120 points)

项目已经发出成功了,还请您过目检查一下,如果可以还请告知一下报错原因,感激不尽!!

by (30.5k points)

您好,我们已测试过您的工程,未做修改,直接打包并打包成功。您需要再次确认您的电脑里Android SDK API 是否安装29及以上,Unity中显示不代表您已经安装。或者您可以尝试删除Android Manifest文件中如下标签:

android:requestLegacyExternalStorage=”true”

by (120 points)

又测试检查一下,发现是要安装Android SDK API29,单独安装高版本的是不行的,已经解决了,谢谢官方

by (180 points)

你好,请问一下如何安装Android SDK API29呢 可以解答一下吗。

...